Dasturlash
0
09.06.2017 17:42 Manuchehr 431 0

VBA dasturlash tili va MS Excel funksiyalaridan ishda foydalanish (davomi)

O‘tgangalgi bolalar bog‘chasi bo‘yicha misolimizni davom qildiramiz. Endigi ishlar uncha bir katta o‘zgarishlar emas, balki oddiy bir kichik VBA dasturlash tilidagi kodlarni o‘rganamiz.

 

Bizni jadvalimizdagi misolda (“jurnal” varag‘ida) 1 dan 5 gacha raqamli putevka va 1 dan 2 gacha protokol kiritilgan xolos. Mabodo agar foydalanuvchi 3-raqamli protokol so‘rab qolsa nima bo‘ladi? Shunda xatolik bo‘lganini chiqarib uni sababini tushuntiradigan oyna bo‘lsa, yana yaxshi deb o‘ylayman.

 

протокол” varag‘iga o‘tamiz. Sahifa (stranitsa)ni tashqarisidagi Q5 katakka ushbu kodni yozdim:

 

=ЕСЛИОШИБКА(ВПР(Q9;ЖурналР!B2:C6;2;0);"хато1")

 

Ya’ni kiritilgan raqamli protokol bo‘lmasa Q5 katakda “xato1” degan yozuv paydo bo‘lishi kerak. Endi “konstruktor rejimi” ga o‘tib, shu varaqdagi tugmani kodini ochamiz va ushbu qatorni qo‘shamiz:

 

If Range("q5") = "хато1" Then MsgBox "Ошибка №1. Нет такого протокола в журнале регистрации"

 

Kodni qiladigan ishi: agar q5 katagida "хато1" degan so‘z turgan bo‘lsa, "Ошибка №1. Нет такого протокола в журнале регистрации" degan xabarni ekranga chiqarish.

 

“Конструктор режими” dan chiqib tugmani tekshirib ko‘ramiz. Buning uchun Q9 katagiga 1, 2, 3 raqamlarini kiritib tugmani bosib ko‘ramiz:

 

1-rasm.

“3” raqamini bosganda shunaqa xatolik berdi.

Xuddi shu usulni “putevka” varag‘ida ham qilsa bo‘ladi.

2-masala. Faylni pdfformatiga o‘tkazish.

Ko‘pincha hujjatlarni pdf formatiga o‘tkazib elektron pochta orqali yuborish urf bo‘lgan. Bu bizni vaziyatimizda kerak bo‘ladimi yo‘qmi masalan protokolni shu formatga o‘tkazadigan tugmani qo‘yamiz. (“Разработчик” menyusi-“Вставить”-“Элементы ActiveX”dan tugmani olamiz)

 

2-rasm. Yangi tugma qo‘yish.

Pdf ga aylantiradigan tugma kodi quyidagicha bo‘ladi:

Private Sub CommandButton2_Click()

ChDir “D:\”

ActiveSheet.ExportAsFixedFormat Type:=xlTypePDF, Filename:= _

“D:\protokol.pdf”, Quality:=xlQualityStandard, IncludeDocProperties:=True, _

IgnorePrintAreas:=False, OpenAfterPublish:=True

End Sub

Kodlarga biroz tushuntirish:

 

Код

Тушунтириш

Private Sub CommandButton2_Click()

CommandButton2 тугмасини босиш процедураси

    ActiveSheet.ExportAsFixedFormat Type:=xlTypePDF

Pdf га ўтказ

ChDir "D:\"

Файл D дискда бўлсин. (Истаса, ўзгартириш мумкин.)

Filename:= _

        "D:\protokol.pdf",

Файл protokol.pdf дея номлансин. (Истаса, ўзгартириш мумкин.)

OpenAfterPublish:=True

Конвертациядан кейин оч. Агар “true”ни  “false”га ўзгартирсак, очмасдан фақат сақлаб қўя қолади.

End Sub

Процедура охири

 

Hammasini qilib bo‘lgach tekshirib ko‘ring.

Эслатиб ўтаман: мақола MS Excel дастури бўйича ўртача билимга эга бўлганлар, формулалар  билан ишлаш тажрибасига эга бўлганлар учун мўлжалланган.

P.S.: Қанчалик даражада тушунарли ёздим билмадим-у, бу мавзу “одноклассники.Ру” сайтида “класс” ишлаш, фейк қилиш, текин ОК ишлаш, “профильни бузиш” ва ҳоказолардан кўра реал ҳаётда кўпроқ фойдали бўлган мавзу деб ҳисоблайман )))).

Umrbek Iskandarovich Matrasulov..

шаблоны для dle 11.2

Ma`lumotnoma
Xabarga izoh qoldirish uchun iltimos saytimizda ro`yxatdan o`ting.
Ommabop yangiliklar